Verification Station is freezing after logging into Citrix

Symptoms

Verification Station is freezing after logging into Citrix, and it is not possible to click on the default menu icons like Files, Edit, etc.

Cause

Limitation of third-party (Citrix) technology, when deployed in some environments.
Specifically, the problem can arise if:
  • PC/laptop plugged into 1 or more external monitors
  • The Windows setting Display > Scale and layout > Change the size of text, apps, and other items is NOT set to 100%:image 2180

Resolution

Method #1
Unplug the external monitor (only use the laptop's built-in screen).

Method #2
Change the Windows setting Display > Scale and layout > Change the size of text, apps, and other items to be 100%

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