Cannot open TWAIN source / Source Initialization Failed / The parameter is incorrect

Issue

When trying to scan an image in FineReader PDF, the following error messages (or one of them) appear:

Cannot open TWAIN source / Source Initialization Failed / The parameter is incorrect.

Cause

There are several causes for these errors:

  • There is no scanner connected to the computer
  • An incorrect driver was used
  • FineReader is not fully compatible with the driver 

Solution

To resolve the issue follow the steps below:

  1. Start FineReader PDF.
  2. In FineReader PDF 16: go to the menu File > Options.
    In FineReader PDF 15: go to the menu Tools > Options.
  3. Select the General tab.
  4. The Select Device... drop-down list should contain several scanner's drivers.
    Try scanning an image using each of them. Finding a scanner driver that successfully produces a scanned image without causing an error solves the problem. 

If the issue was not resolved, try to scan an image using the scanner's interface: How to switch to the scanner's interface in FineReader PDF.

If all of the scanner's drivers and scanning with the scanner's interface produce errors, use the TWAIN_32 Twacker application to check if the scanner's drivers are working properly.

  1. Close FineReader PDF.
  2. Download twack_32.zip attached to the article below.
  3. Unpack the downloaded archive and install the Twacker application by double-clicking Twack_32.exe.
  4. Open the File menu in TWAIN_32 Twacker and select the Acquire item.
  5. Click the Scan button in the dialog that appears.
  • If Twacker successfully scans an image, one of the scanner's drivers is working properly. Find out which one it is by opening the File menu in Twacker and selecting the Select Source item. The driver used for the successful scan will be indicated in blue. Select the same driver in FineReader PDF and try scanning. If FineReader PDF still produces an error, please submit a request.
  • If Twacker cannot scan an image, the drivers for the scanner are not working properly. In this case, an update or reinstallation of the scanner's drivers is required. You can contact the technical support service of the scanner's manufacturer for assistance with the reinstallation of the scanner's drivers.

Have more questions? Submit a request

Comments

1 comment

  • Avatar

    Joseph Nickel

    1. Open the Tools menu and select the Options item??????? There's no "tools" menu or options item to be found.  Please be more specific.
    0

Please sign in to leave a comment.