No Processing Server/Station trace log stored.

Symptoms

Write Processing Server/Station trace log options are enabled, but no logs are saved.

Cause

The changes to the settings may have not been written to the Windows Registry.

Resolution

The trace logging settings are stored in the following Windows Registry key: HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\FlexiBr.

  • IsLoggingEnabled - 1 means that the logging is enabled. Required value for the trace logging.
  • LoggingLevel - level of logging detail from 1 (minimum detail) to 9 (maximum detail). LoggingLevel is set to 5 by default.
  • LoggingManagerMaxLogFileSize - the maximum allowed size of one log file in bytes (1 MB by default).
  • LoggingManagerMaxOldLogsFilesCount - the maximum allowed number of log files (10 by default).
  • LoggingManagerMaxOldLogsFilesSize - maximum total size of all log files in bytes (10 MB by default).
  • LoggingFilter - the types of events that will be logged.
    Sample filter string: +Licensing;+AppState;-*;+Monitoring. This filter enables the Licensing and AppState logs. The Monitoring log is disabled by the -* mask.

It is also required to restart the FlexiCapture Windows Services (Processing Station and Processing Server) for the changes to the Windows Registry to take effect.

Additional information

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