Error during installation: To continue installation of the Application Server component, please install Microsoft .Net Core 3.1 (or above)

Symptoms

The following message is continuously shown when trying to install server components of FlexiCapture 12 Distributed starting from build 12.0.4.803+ even if Microsoft .Net Core 3.1 is installed:

To continue installation of the Application Server component, please install Microsoft
.Net Core 3.1 (or above) - Windows Server Hosting module. You can find this module available
in the External Components section of this distributed kit, or download it from microsoft.com
website

Cause

During the installation, a ..\Servers x64\Bin\Support\CheckIisAspNetCoreReady.ps1 script file from the distribution package is launched. The preset condition inside the script is causing the script check to fail.

Resolution

  1. Check if the .Net Core is installed in the Apps & features:
  2. If so, copy all the content of the installation distribution image, i.e. ABBYY_FlexiCapture12_Distributed_R4Ux_12.0.4.8xx.iso, to a separate folder.
  3. Edit the CheckIisAspNetCoreReady.ps1 script located under the path …<FOLDER NAME>\Servers x64\Bin\Support so that the code lines below:
    if( !$aspNetCoreModule ) 
    {   
      Exit 1;  
    } else {
      Exit 0;
    }
    will be substituted with the following one:
    if(true) 
    {      
    Exit 0;

    }
    As a result, the script will look as in the screenshot below:

  4. Save the modified script.
  5. Launch the installation Autorun from the local folder, where all the files were copied.

Note: If CheckIisAspNetCoreReady.ps1 does not exist, please try to download the distribution kit again and run an installation from scratch.

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Comments

3 comments

  • Avatar

    Russell Kent

    We have 12R4U3 (12.0.4.979) but still have this problem. And the workaround does not work because no such "check*" Powershell script exists in the ISO. See case #574934

    0
  • Avatar

    Andras Nagy

    Thank you for the info Russel! Unfortunately I am stuck as well because of this problem. The advised workaround does not work.

    1
  • Avatar

    Russell Kent

    Be advised that Malwarebytes sometimes interferes with IIS running. We have IIS configured appropriately, but it wasn't listening on port 80, and IIS Manager showed the site stopped with no "start" option available. To remediate, we halted Malwarebytes, completely uninstalled IIS, restarted the server, stopped Malwarebytes again (it restarted with the server reboot), re-installed IIS, removed all the .Net 6.0.18 stuff that the "External Components" package added, installed the .Net 3.1 Windows Server Hosting package (from https://dotnet.microsoft.com/en-us/download/dotnet/3.1 ) and then re-installed FC12. We have yet to restart the server to see if Malwarebytes continues to interfere (on reboot).

    1

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