Symptoms
The following error occurs when trying to obtain an Access Token for Public API or when using connectors:
{"error": "invalid_grant", "error_description": "invalid_username_or_password"}
Cause
One of the possible reasons is that the user email used to obtain the Access Token belongs to multiple tenants simultaneously. In such a case, the Access Token URL need to contain the Tenant ID.
Resolution
Please re-check the endpoint specified on the connector side or where the API call is performed.
If the email address is present in multiple tenants, the Access Token URL has to be specified in the following format:
http://vantage-<instance>.abbyy.com/auth2/<tenantID>/connect/token
To get the Tenant ID, check the Tenant Administration window by navigating to Configuration > General > Tenant ID.
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