FlexiCapture SDK services are not visible in the Control Panel and in the Windows Services

Symptoms

The FlexiCapture Runtime SDK was installed successfully, however the program is not shown in the Control Panel or Windows services.

Cause

The installation system is designed to prevent installation in a directory where it detects existing installations of the products. This is done to avoid conflicts and ensure a clean installation process. 

Resolution

If you encounter this issue, it is recommended to uninstall the previous installations or choose a different installation path to proceed with the installation successfully. When the product is installed in the new path, all products will be correctly re-registered in the new path.

The re-installation can be performed in several ways:

  1. If license allows installation of the full version of the FlexiCapture SDK 12:  
    1. Run installation through FlexiCapture SDK 12 (x64).exe file (not ...SDK 12 Runtime file)
    2. Select Repair among the Modify/Repair/Uninstall options
    3. Leave the default settings on the Program Features installation view
    4.  On the Installation Details installation view, specify the new installation path by adding, for example, suffix "NEW" at the end:
      C:\Program Files\ABBYY SDK\12\FlexiCapture SDK NEW
    5. Specify the Customer Project ID if it is known, or leave it blank
    6. Disable option Use of Activation-token file   
  2. If license prohibits installation of the full version of the FlexiCapture SDK 12:
    1. Install FlexiCapture SDK 12 Runtime (x64).exe by running it from the command line with the specified parameter values: 
      <Path_do_distr>"ABBYY FlexiCapture SDK 12 Runtime (x64).exe" INSTALLDIR="C:\Program Files\ABBYY SDK\12\FlexiCapture SDK NEW" REGISTERCOM="Force"

      Please note, for Runtime installation, REGISTERCOM="Force" parameter is mandatory.

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