Uninstalling FineReader Engine completely

Symptoms

When FineReader Engine is uninstalled using the Add or Remove programs dialog (Start > Settings > Control Panel > Add or Remove Programs), the following (or similar) error message may appear:

"There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action Launch_deinstall_VisualComponentsX.dll, location: C:\Windows\system32\, command: regsvr32.exe /s /u "C:\Program Files\ABBYY SDK\11\FineReader Engine\Bin\VisualComponentsX.dll".

Cause

The error appears when the previous version of the engine was not uninstalled completely.


Solution

Try to remove the previous version of FineReader Engine completely, as described below:

  1. Delete all files from the previous FineReader Engine installation manually.
  2. Clean out the registry entries left from the previous FineReader Engine installation:
    1. Create a folder on a hard drive (this folder can be located on any drive and have any name, for example, C:\EngineUninst).
    2. Download the MsiZap utility.
    3. Run the following command from the command line:
    • For FineReader Engine 11: C:\EngineUninst\MsiZap.exe TW! {AFE11000-0001-0000-0000-074957833700}
    • For FineReader Engine 12: C:\EngineUninst\MsiZap.exe TW! {AFE12000-0001-0000-0000-074957833700}

Wait until the process is completed. All FineReader Engine keys will be removed from the registry, and the DOS window will close automatically.

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.