Online license errors & solutions

Symptoms 

If an Online License is used, then each time one of the counter-increasing methods is called (a full list of these methods is in the Counter Increasing Methods article of the Onlne Developer's Help) FineReader Engine attempts to connect ABBYY licensing server by the Internet. If the connection fails, then the following error message will be displayed:

Failed to communicate with the online licensing service

or the following error message:

Failed to load Engine with online licensing due to a timeout

Cause 

This error may occur if the product is used on a computer with strict firewall settings.

Resolution 

Please enable *.abbyy.com and ports 80, 443.

If the firewall type does not allow using mask *.abbyy.com, then please use the following machine names**:

  • account.abbyy.com
  • personal-cloud.abbyy.com
  • license-cloud.abbyy.com
  • us-license-cloud.abbyy.com
  • Admin-cloud.abbyy.com
  • mail-cloud.abbyy.com
  • payment-cloud.abbyy.com

Please don't bind the firewall rules to IPs. The IPs are volatile and could be changed without any warnings. 

* "Online" license is a former "Cloud" license until FineReader Engine 12 Release 3 and actual for FlexiCapture Engine 12. 

** Please note that these addresses are not intended to be pinged. To check the Licensing service availability, please follow the instructions from the How to check the availability of a Licensing Service for Online Licenses article.

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