The warning message "There are no digital signature certificates installed on this computer" occurs while trying to add Digital Signature

Symptoms

The following warning message occurs while trying to add a Digital Signature in FineReader PDF:

"There are no digital signature certificates installed on this computer".

Cause

The most common cause is that the signature does not have a valid root certificate. 

Resolution

Digital signatures available for signing in FineReader PDF are located in the Personal certificate store of a user account. All certificates that contain a Private Key are shown in the application. Please make sure that an appropriate Trusted Root Certificate for the needed signature is available.

To see the list of the certificates available in the MS certificate Personal Storage:

  1. Press Windows+R, type certmgr.msc and click OK.
  2. Open Personal > Certificates.
  3. Find the certificate used for signing in FineReader PDF.
  4. Right-click on it, select Open and make sure that the certificate is valid.
  5. Open the Certification Path tab and make sure that all certificates in the tree including the Trusted Root Certificate are valid.

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After the document is signed with a valid signature, PDF viewer may display it as invalid on a computer that does not have a Trusted Root Certificate that was used to sign the document.

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Comments

2 comments

  • Avatar

    Volker Wittmann

    thank you, but what to do, if everything is checked, but Abbyy won´t display the desired signature? I´ve got a certificate on a smartcard, that works with a cardreader & secsigner, but won´t work with AbbyFineReader - I´ve checked on Window`s certificate-manager:

    • certification-path and valid: CA-root
    • certification-path and valid: intermediate certificate
    • certification-path and valid: personal public key 
    • Signaturealgorithmus type sha256RSA
    • public key type RSA

    What else might be wrong, why Abbyy won´t display my certificate?

    Best regards Volker

    0
  • Avatar

    Victoria Dvornikova

    Hello Vw,

    I have created a support ticket based on your comment. Please await a reply from our Support Team.

    0

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