Mobile Web Capture "Error performing wasm action: Check_License"

Symptoms

Getting an error message after License update/extension:

Check_License

Cause

License naming issue in older versions of the product. 

Resolution

The reinstallation of the Mobile Web Capture product using the latest build may be needed. Please delete our previously distributed folder and download the one from the latest product version.

The code sample is located in the sample folder and includes client and server parts:

  • sample proxy server implementation (sample/server)
  • front-end ABBYY Mobile Web Capture implementation (sample/client)

Server configuration

To test the sample on a computer, a local server should be configured. To deploy a basic Node.js server locally perform the following steps:

  • Install the Node.js platform on your computer
  • Place the license file into the sample\client\libs\js folder. Please notice, that the file name should be MWC.ABBYY.License. Rename your license file if necessary.
  • In terminal/CMD/PowerShell do the following:
    • Navigate to the sample/server folder
    • Run npm install
    • Run npm start
  • The server will be available on http://localhost:3030

Note: Ensure that no cache is stored. Please, clean it for the Google Chrome browser or one you are using.

In case our recommendations do not solve the issue, please provide ​console logs, the HAR file from developer mode from the Browser and a zip archive, which will contain the Mobile WebCapture project to reproduce the issue on our side

 

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.