Online license does not work: Failed to communicate with the online licensing service

Symptoms

FineReader Engine is unable to initialize with an Online license. The C:\ProgramData\ABBYY\SDK\12\Licenses\NetworkServer*.log file contains entries like

Online licensing error: f73967e8ce6dd8b55eb17e955eb17e9, 0x0000 0x0003 0x0023

Also, there is no "Go Daddy Root Certificate Authority - G2" line in the Trusted Root Certification Authorities - Certificates section of Certificate Manager (certmgr.msc).

Cause

When the Trusted Root Certification Authority of GoDaddy is missing on a certain machine, it leads to the revocation check problem while establishing the SSL connection with the ABBYY Licensing Server. As a result, the Online license cannot work on that machine.

Resolution

To resolve the issue, please try to add the missing CA with the CertMgr.exe utility:

  1. Get the certificate files from ABBYY sites (https://license-cloud.abbyy.com/heartbeat and account.abbyy.com). For example, in Google Chrome you may do the following:
    • Click the View site information button in the address bar and select the Connection is secure option (the padlock icon):
    • Click the Show certificate button:
    • Click the Export button on the Details tab:
    • Save the certificate to a file (for example, using license-cloud.cer as a filename)
  2. Install CertMgr.exe as a part of Windows 10 SDK (download) or download the utility directly from ABBYY Sharepoint: link
  3. Run the command prompt or Powershell in Administrator mode (cmd.exe - right click - Run as Administrator) and run the following command:
    CertMgr.exe -add license-cloud.cer -s -r localMachine root

    In case you get the Failed to save to the destination store error after executing a command, the following article might help: https://social.msdn.microsoft.com/Forums/windowsdesktop/en-US/0302488e-eb00-4385-92b8-f06317b586dc/certmgrexe-install-thrusted-publisher-certificate-problem?forum=windowssdk 

  4. After adding the certificate with CertMgr.exe, open Certificate Manager (Run - certmgr.msc) and see if GoDaddy appeared in the Trusted Root Certification Authority list:



  5.  Run the following command:

    certutil -verify -urlfetch license-cloud.cer 

    There should be a line Leaf certificate revocation check passed at the end of the command output which means certificate checking has been passed successfully.

Additional Information

In extra cases, you might get the "Failed to communicate with the online licensing service" error even when all the requirements from the Online protection tips article are met. The issue could be caused by the missing Trusted Root Certification Authority on the used machine.

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.