Issue
A subscription for iOS can not be purchased (the circle is spinning, etc). How to purchase a subscription to the Premium Account for mobile application?
Cause
The situation may be caused by some technical issues or some settings not being configured on the iPhone.
Resolution
If the purchase of a subscription for a mobile application (Business Card Reader, FineReader PDF) cannot be conducted for some technical reason, please try to do the following:
- Restart the mobile device.
- Check that an Internet connection is stable and\or try to switch between Internet connection types (Wi-Fi, LTE, etc.).
-
Try to purchase the subscription.
In case the issue persists, please make sure that in-app purchases are enabled in the Screen Time settings on the device. To turn them on, follow the instructions below:
- Go to Settings on iPhone.
- Tap Screen Time > Content & Privacy Restrictions:
This option is turned on: tap iTunes and App Store Purchases.
This option is turned off: skip this instruction, and go to the next solution. - Tap In-app Purchases.
- Choose Allow.
- Try to purchase the subscription.
If all the instructions from above did not help or the Content & Privacy Restrictions option was turned off, then the other solution is to check and update the information associated with the Apple ID. Please do the following:
- Go to Settings on an iPhone and tap on the name at the top of the screen.
- Choose Payment & Delivery and enter the Apple ID and password if needed.
- Verify that the credit card or PayPal information is up to date. If needed, add or edit the payment information.
Additional information
If you need to change or update your Apple ID payment method
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