Symptoms
The error "The button 'Business unit must be found in database' refers to a rule that is disabled" occurs in an attempt to save Document Definition.
Cause
The rule "Business unit must be found in database" is disabled in the Document Definition.
Resolution
In order to resolve the issue, it is required either to enable the rule or remove the Find button.
To enable the rule, follow these steps:
- In the Document Definition Editor open BU group properties and navigate to the Rules tab.
- Set Show rules parameter as "owned by BU".
- Enable the rule named "Business unit must be found in database" as on the screenshot below:
If you want to disable the rule, but still receive an error on Document Definition saving, the Find button should be removed from the form:
The same situation is valid for the rule "Vendor must be found in database".
Comments
2 comments
Ankit Nayak
We had removed the "Find" button from the form which had fixed the issue. However, now we have Business Unit requirement in the same invoice project. So, we added the Find button and enabled the database check rule again, however, now the lookup button doesn't work and gives the error "The button refers to rule “” which is disabled” .
refer ticket 411889
Viacheslav Prodan
Dear Ankit.
I see that our customer support staff has started an investigation into the request that you submitted.
Best regards,
Viacheslav Prodan
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