Calculate Sum rule does not set field value to 0 when summarized fields are deleted.

Symptoms

The field calculates the sum of the totals of each line item, or another set of fields, with a "Calculate Sum" rule. When all the line items or target fields are deleted, this field's value should reset to zero but it does not happen.

 

Cause

Calculate Sum rule is not triggered when one or several fields in rule settings are absent (according to the rule settings) because in such case basic condition for rule execution is not satisfied.

 

Resolution

There are several approaches to reach desired behavior:

  • Set the Data Type to "Number" and default value to "0":

  • Set up a rule chain to nullify the field value if target fields are deleted
  • Use different kind of rule (for example, script rule)
  • Double-check the field consistency and nullify the field value with event handlers or script stage.

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