Task Scheduler did not launch task "\ABBYY Update Datasets\" because instance "{...}" of the same task is already running.

Symptoms

1. This happens when Windows Task Scheduler or any other task scheduler software tries to run a scheduled update of desired datasets and you receive the following error message:
"Task Scheduler did not launch task "\ABBYY Update Datasets\" because instance "{9e8e1535-8688-4580-88dd-e8629be7187e}" of the same task is already running."

 

2. Also, in such cases, the below update command runs fine in the command prompt without using any Task Scheduler software.

FlexiBRSvc.exe please update dataset "http://myAppServer/ProjectId/ProjectName" "Invoice" "Vendors"


3. In addition to the above - failed imports start to fill up the cache by the following path: C:\Users\*username*\AppData\Local\Temp\
And in similar cases, when large dataset updates were interrupted, it would create its temp files in the Temp folder.  Subsequent failures usually led to a buildup in the user's (service account) temp folder.

Cause

This particular error message might be caused by the 'Runtime Broker' application not having permissions to Service Account that runs the actions on the task. 

In this case, you will likely find a periodical error message in the security tab in Windows Event Viewer, which will coincide with the schedule on the task:
"The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{D63B10C5-BB46-4990-A94F-E40B9D520160}
and APPID
{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
to the user ABCD1\srv-abbyytest SID (S-1-5-21) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool."

But mostly the issue happens when the Dataset update task is run by the same account as the ABBYY FlexiCapture 12 Processing Server service.

 

Resolution

Once a separate account is used to run the task, you should not experience any errors in Task Scheduler software or any failed imports filling up the cache.


Related articles: 

- Updating data sets
- How to schedule a data set update for FlexiCapture 12 Distributed
- How and when to clean up ...\AppData\Local\Temp folder for FlexiCapture

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