ERR_DBMNGR_INVALID_DATABASE_VERSION in Oracle Database (NLS_LANG)

Symptoms

An exception is thrown when accessing an Oracle database:

Exception: System.Web.Services.Protocols.SoapException
Message: ERR_DBMNGR_INVALID_DATABASE_VERSION

Cause

This error could be caused by a multitude of factors, but one of the causes for this could be altered Oracle's NLS_LANG settings in the registry. 

The NSL_LANG settings are responsible for setting a locale that Oracle DB uses. The assumption is, that a value different from the system locale could possibly cause compatibility issues between Oracle DB and FC12.

Resolution

In one of the cases with this type of error, removing the NSL_LANG values from OracleHome registry path resolved the issue. This makes Oracle DB to use the default value set for the system (making it the same as FlexiCapture uses.

 

Note: Because this is an issue caused by Oracle Database settings, but not FlexiCapture itself, it is better to address it to the Database Manager.

 

Additional information about the Oracle's NLS_LANG settings is available here.

Was this article helpful?

0 out of 0 found this helpful

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.

Recently viewed