ABBYY FlexiCapture Connect fails to import documents: "Bad JSON escape sequence" error

Symptoms

ABBYY FlexiCapture Connect Windows service doesn't start and produces "Could not parse the JSON file" and "Bad JSON escape sequence" errors in the FlexiCapture Connect log generated in %LocalAppData%\ABBYY\FlexiCapture\Connect\Logs.

Example:

2021-12-03 00:04:22.278 +03:00 [Information] Configuration Result:

"[Success] Name ABBYY.FlexiCapture.Connect

[Success] DisplayName ABBYY FlexiCapture Connect

[Success] Description Abbyy.FlexiCapture.Connect

[Success] ServiceName ABBYY.FlexiCapture.Connect"

2021-12-03 00:04:22.337 +03:00 [Information] "Topshelf" v"4.1.0.172", .NET Framework v"4.0.30319.42000"

2021-12-03 00:04:22.437 +03:00 [Error] Unhandled exception.

System.FormatException: Could not parse the JSON file. Error on line number '10': '"import": {

"directory": "\\FC12-VM\Import",'. ---> Newtonsoft.Json.JsonReaderException: Bad JSON escape sequence: \I. Path 'projects[0].import.directory', line 10, position 33.

Cause

The full absolute path to the import/export folders or relative path to a shared folder in UNC format contains unescaped characters.

Resolution

Special characters (e.g. backslash, tab, newline symbol, etc.) should be escaped in the JSON file so it could be parsed correctly.

We need to modify the ABBYY FlexiCapture Connect configuration file (config.json) located in C:\Program Files (x86)\ABBYY FlexiCapture Connect\ to escape all special characters.

For example, in the last line of the log above we may see that: 

"directory": "\\FC12-VM\Import"
have to be replaced with:
"directory": "\\\\FC12-VM\\Import"

Additional information

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.