Online License doesn't work with specified proxy server

Symptoms

  1. The Network Server logs could contain the following errors:
    Online licensing error: <...>, 0x0000 0x0003 0x0006
    Online licensing error: <...>, 0x0000 0x0003 0x0023
  2. Checking the availability of a licensing service and/or "http://certificates.godaddy.com/" through curl with proxy returns the response status code 5xx, instead of 200
    curl -v https://license-cloud.abbyy.com/heartbeat -x <proxyhost.com[:port]>
  3. When performing the last step from the article Failed to communicate with the online licensing service due to missing Trusted Root CA:
    certutil -verify -urlfetch license-cloud.cer
    returns the following result:
    MicrosoftTeams-image1.png
  4. Setting the IsNoRevoke="Yes" (if it's implemented for FineReader Engine 12 build, currently being in use) in the LicensingSettings.xml file, didn't have an impact on the situation.

Cause

The licensing server wasn't configured for using a specified proxy and/or services for the functioning of online licenses are inaccessible through proxy.

Resolution

  1. Configure both LicensingSettings.xml, which should be located at
    • for a 32-bit operating system:
      • %CommonProgramFiles%\ABBYY\SDK\12\Licensing\
      • <Installation Folder>\Bin\
    • for a 64-bit operating system:
      • %CommonProgramFiles(x86)%\ABBYY\SDK\12\Licensing\
      • <Installation Folder>\Bin64\ (if available)
      • <Installation Folder>\Bin\ (if available)
        Here is a sample with the proxy server settings for Online Licensing:
        <LocalLicenseServer>
          <OnlineLicensing Timeout="timeout_time" ProxyServer="http://<server_name>:<port_number>" ProxyAuth="<login>:<password>" />
          <ConnectionProtocol ProtocolType="<Protocol type>" />
        </LocalLicenseServer>
        Please fine more details on the LicensingSettings.xml file's settings in FineReader Engine 12 Developer's Guide.

  2. Add the following subdomains to the whitelist for the proxy server:
    • *.abbyy.com
    • *.godaddy.com

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.