Application fails to run with the following error: ABBYY Licensing Service is unavailable. The RPC server is unavailable.

Symptoms

When trying to run an application that utilizes an SDK product, or trying to activate/update/deactivate a license via the License Manager, the following error occurs:

ABBYY Licensing Service is unavailable. The RPC server is unavailable.

Cause

This error message usually appears when the product installation is configured incorrectly.

Resolution

Сheck the following:

1) The Licensing Service is running on the server:

  • Go to Control Panel > Administrative Tools > Services.
  • Select the correct service, e.g. ABBYY FineReader Engine 12 Licensing Service.
  • Press Start the service if the service is not running, or Restart the service if it is. 

2) All settings for the Licensing Service are correct. The settings are specified in the LicensingSettings.xml files found in 2 locations:

  • Product licensing settings – Bin64 subfolder of the product installation folder on the machine running the SDK-based application;
  • Licensing Service settings – %CommonProgramFiles(x86)%\ABBYY\SDK\12\Licensing (FineReader Engine 12) or %CommonProgramFiles(x86)%\ABBYY\FCSDK\12\Licensing (FlexiCapture SDK) folder on the machine running the Licensing Service.

Try to set or change the port number in the network settings of the LicensingSettings.xml both for the Licensing Service and for the product manually:

  1. Change the LicensingSettings.xml file for the Licensing Service:
    <?xml version="1.0" encoding="utf-16"?>
    <LicensingSettings xmlns="http://www.abbyy.com/Protection/LicensingSettings">
    <LocalLicenseServer>
    <ConnectionProtocol ProtocolType="TCP/IP" EndPointName="port_number" />
    <EnableIKeyLicenses Enable="no" />
    <EnableCodeMeterLicenses Enable="no" />
    </LocalLicenseServer>
    </LicensingSettings>
  2. Change the LicensingSettings.xml file for the product:
    <?xml version="1.0" encoding="utf-16"?>
    <LicensingSettings xmlns="http://www.abbyy.com/Protection/LicensingSettings">
    <LicensingServers>
    <MainNetworkLicenseServer ServerAddress="server_address" ProtocolType="TCP/IP" EndPointName="port_number" />
    </LicensingServers>
    </LicensingSettings>
  • The server_address value should be set to the address of the server where the Licensing Service is installed (localhost and 127.1.1.0 for the locally installed Licensing Service).
  • The port_number value should be set to the number of the port where the Licensing Service is available (by default, 3022 for FineReader Engine 12 and 3024 for FlexiCapture SDK).

3) Nothing like closed ports or insufficient user rights prevents the Licensing Service’s appropriate work. To check if the port on which the service should be available is open on the server and reachable from the client workstation, the Test-NetConnection PowerShell command can be used, for instance:

Test-NetConnection -computername server_address -port 3022

4) The error can also occur when the product version and the Licensing Service version from different distributions are used. In this case, it is recommended to reinstall the product on the machine where the error occurs.

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