Online licensing connection problem

Symptoms

Errors "Online licensing connection problem" and "Online licensing error" appear in NetworkServer.log file that is present in c:\ProgramData\ABBYY\SDK\12\Licenses folder.

Cause

These errors will appear when the engine is not able to connect to ABBYY online licensing server.

Resolution

You need to check and edit if required the LicensingSettings.xml stored under the C:\Program Files (x86)\Common Files\ABBYY\SDK\12\Licensing directory. Add the IsNoRevoke="yes" option to the OnlineLicensing section of XML, so the resulting file can look as follows:

<?xml version="1.0" encoding="utf-16"?>
<LicensingSettings xmlns="http://www.abbyy.com/Protection/LicensingSettings">
<LocalLicenseServer>
<OnlineLicensing Enable="yes" IsNoRevoke="yes"/>
<ConnectionProtocol ProtocolType="LocalInterprocessCommunication" />
</LocalLicenseServer>
</LicensingSettings>

After editing the LicensingSettings.xml file, please restart the ABBYY Licensing Service (ABBYY.Licensing.FineReaderEngine.Windows.12.0) via Task Manager or services.msc tool:
 

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