"This batch type contains multiple Document Definitions. You must use a classifier for this batch type." Error

We use Flexicapture for Invoices 12 to capture and process incoming POs from multiple sources.  We have been using the "Order" doc definition to process any POs that don't have a dedicated layout assigned, or when the vendor makes PO formatting changes and doesn't notify us ahead of time.  It had been working pretty well.  Recently, any time a doc arrives that would fall into the non-layout category, we get the following error when attempting to process: "This batch type contains multiple Document Definitions. You must use a classifier for this batch type."  I am having trouble nailing down the cause and/or a resolution.

I have opened each of the Order definitions for testing. We have several: the original one with some export destination tweaks and a few copies that I work from so I don't break the original.  If I run a test of the order def in Project Setup Station, it runs without incident.  If I create a test batch using a copy of a customer PO, again in Project Setup Station, it runs against a production PO without a problem.

It only generates the error when running live processing. If I try to send a doc from exceptions back to verification and clear the results, I still can't manually match the definition successfully.  Typically get the same error, or worse.

So, that leads me to believe that the error is a product of a project misconfiguration rather than a def or layout issue specifically.  Possibly even in the recognition order.  I have read that if the error percentages are set "just right" on one or more defs/layouts that this error can be generated since the incoming doc matches multiple sets.  Any way to set the debug level on the logging higher to see exactly what is being processed and what it might be hitting (if this is the case)?

The frustrating part is that it used to work very well.

Anyone else run into this or a similar issue? 


Was this article helpful?

0 out of 0 found this helpful


1 comment

  • Avatar
    Aditya Anshumaan

    I am facing a similar issue as well and getting the same error kindly share a solution for the same


Please sign in to leave a comment.