PDF Transformer + ver 4 Error: timeout starting and initializing server Answered


This is very frustrating. I have PDF Transformer+ ver 4.0 installed on Windows 7 Ultimate x64 SP1.
My scanner is a Canon 9000F Mark II.

Everything was working fine until recently. Now, when I start PDF Transformer for the 1st time after starting or rebooting the computer, and click the Scan button in PDF Transformer, there is a delay of about 30 seconds, then a dialog pops up with the error: Timeout starting and initializing server.
After I click OK, the scan dialog appears, and I am able to scan a document.

I searched the Abbyy knowledgebase and found something relating to scan "stations", but I have no scan station. My scanner is connected to my PC via USB.

When I start the Cano-Scan utility, it runs fine. No delay, no errors.
Checking 'imaging devices' in Device Manager I see the scanner is working properly.

I have tried swapping the scanner to another USB port (which is on a different USB hub). The driver installs automatically (from Windows Update) when I do this, but I still get the same error when I try to scan for the first time with PDF Transformer.

The driver I am using is this one: "mp68-win-9000fmkii-1_00-ejs.exe"
I tried downloading another driver from the Canon support site: "sd68-win-9000f-16_0_5-ej.exe"
Result: Same as the other driver.

I completely un-installed Abbyy PDF Transformer and re-installed. No change.
Un-installed and re-installed scanner driver. No change
Tried installing the driver as Administrator. No effect.

Since I have a dual-boot (actually triple boot with Ubuntu) Win 7/win 10 I installed PDF Transformer on Windows 10.
No problems. No error. PDF Transformer communicates properly with the Windows 10 driver for the scanner. I did not need to install another driver.

Oh, and I forgot to mention that I have ESET Internet Security installed on Windows 7 (but not on Windows 10).
i tried pausing protection and firewall, but this had no effect.
Perhaps I should have paused the protection while re-installing PDF Transformer?

Any ideas?



Was this article helpful?

1 out of 1 found this helpful



  • Avatar
    Frank Runner

    I have been doing further research into this and found the following:

    If I power cycle the scanner, the error does not reappear (so long as this is not the 1st time I am doing a scan after starting the system)

    If I cycle the Windows Image Acquisition (WIA) service, I can reproduce the error without having to restart the system.

    this has led me to think that PDF Transformer is having trouble communicating with the WIA service the first time a scan is performed, but remembers some parameter after that.

    I am going to download and install ABBYY FineReader trial and see whether or not I get the same error.

    Update: Installed FineReader 14 Trial. No problems with scanner. I can use either the WIA or the Twain driver.
    Interesting that PDF Transformer doesn't show the Twain driver the first time it is run after install. I wonder whether there is a stand-alone Twain driver I can use with Transformer.

    Update #2: Looks like WIA is a Twain driver...

  • Avatar
    Frank Runner

    OK. So I have solved my own question. The culprit was "LG AirDrive", which I had installed a while ago. This was also a WIA driver. Apparently, PDF Transformer was finding this driver first, waiting for it to time out, and throwing the error. Then, once OK was clicked, it hooked up with the scanner driver and brought up the scan dialog.

    Either PDF Transformer does not have an Options menu, or I don't know how to bring it up (tried Alt, Ctrl, shift). But FineReader does have this, so I was able to see that one of the choices for scanner was LG AirDrive. So I simply uninstalled AirDrive to fix the problem.

    I hope that this thread - even without any further posts - will be of help to someone looking for a solution to this problem.


Please sign in to leave a comment.