Community

Original File vs Export File

hi every one I have a question about original file and after input file in hot folder.

Why some thing or some sentence lost after input into ABBYY Hot Folder?

Right now I already disable everything about Image processing, but everything will be same.

ABBYY have another config about image processing yes or no ?.

Thank you
James

0

Comments

13 comments

  • Avatar
    Vladislav Suvorov
    Hello,

    Please send me(you can do it using private messages) watermark's original image so I can determine what exact algorithm will help solve this issue. Most likely it's caused by some image binarization problem which I could not reproduce(watermark from example image turned black for me).

    Regards,
    Vladislav
    0
  • Avatar
    laptorkung
    Hello,

    Please send me(you can do it using private messages) watermark's original image so I can determine what exact algorithm will help solve this issue. Most likely it's caused by some image binarization problem which I could not reproduce(watermark from example image turned black for me).

    Regards,
    Vladislav



    Sorry for your request. I can not send original to you because in my case water mark of customer.

    thank you for your help.

    Regards,
    James
    0
  • Avatar
    Vladislav Suvorov
    If that's not possible then I'd advise trying to change Image preprocessing settings(convert to black and white, despeckle checkmarks in particular) to see if it has any effect.
    Also, if you are using dropout form and documents have background color it is possible that watermark is treated as background as well. Investigating this possibility requires more information and most likely document itself as well.

    Hope that helps,
    Vladislav
    0
  • Avatar
    laptorkung
    If that's not possible then I'd advise trying to change Image preprocessing settings(convert to black and white, despeckle checkmarks in particular) to see if it has any effect.
    Also, if you are using dropout form and documents have background color it is possible that watermark is treated as background as well. Investigating this possibility requires more information and most likely document itself as well.

    Hope that helps,
    Vladislav



    For your recommend about convert to black and white, despeckle function .I need to enable or disable this?
    0
  • Avatar
    Vladislav Suvorov
    Hello,

    Please try changing those and in different combinations they might give a good result.
    Sadly, without project I can't realistically say how binarization affects your images and ways to solve the problem.

    Regards,
    Vladislav
    0
  • Avatar
    laptorkung
    Hi again

    Right now I already got some information about image quality drop after input to ABBYY.

    Can I Improve this point to keep everything on electronic paper will be same as original?

    Regards,
    James
    0
  • Avatar
    Vladislav Suvorov
    Hello again,

    FlexiCapture is made to remove watermarks if you choose to convert to black and white in Image Preprocessing Settings just so they don't affect recognition. So your case is absolutely normal and isn't a quality drop in any way since program is working as intended.
    To keep watermarks please consider making your settings precisely fit the attached example(FlexiCapture will most likely export the same image as input one but recognition quality may decrease). View->Document Editor->"Show images in black and white" checkmark if disabled will allow to view images in full color on Project Setup and Verification stations.
    If that still doesn't help please send me screenshots of the same settings I provided in attachment files and also please answer questions below:
    1)What format are your input images?
    2)Are your input images color or grayscale?

    Regards,
    Vladislav
    0
  • Avatar
    laptorkung
    Hello again,

    FlexiCapture is made to remove watermarks if you choose to convert to black and white in Image Preprocessing Settings just so they don't affect recognition. So your case is absolutely normal and isn't a quality drop in any way since program is working as intended.
    To keep watermarks please consider making your settings precisely fit the attached example(FlexiCapture will most likely export the same image as input one but recognition quality may decrease). View->Document Editor->"Show images in black and white" checkmark if disabled will allow to view images in full color on Project Setup and Verification stations.
    If that still doesn't help please send me screenshots of the same settings I provided in attachment files and also please answer questions below:
    1)What format are your input images?
    2)Are your input images color or grayscale?

    Regards,
    Vladislav


    1)What format are your input images?
    Most is PDF files.
    2)Are your input images color or grayscale?
    mix

    second one is OK.I will try this but the first picture(as your attachment) can not use because I use Jscript for export.

    this is my code.

    var imageOptions = FCTools.NewImageSavingOptions();
    imageOptions.Format = "pdf";
    imageOptions.ColorType = "BlackAndWhite";
    imageOptions.Resolution = 600;

    Can you recommend me to fix my code for best export file.

    Thank you!!!

    Regards,
    James
    0
  • Avatar
    Vladislav Suvorov
    Hi James,

    If you are using script for export please change this property:
    imageOptions.ColorType = "BlackAndWhite"; -> imageOptions.ColorType = "FullColor";
    this will enable images to be saved with bit depth of a color image(color images will remain colorful, grayscale images won't visually change either).
    For more details please refer to Appendix > Using scripts in ABBYY FlexiCapture > Scripts for customizing processing stages > Objects > IExportImageSavingOptions

    Hope that helps,
    Vladislav
    0
  • Avatar
    laptorkung
    Hi Vladislav,
    Thank you for your recommend and fast response.
    I will try this.

    In my ABBYY Project I observe after I put document into ABBYY FlexiLayout Studio 10 I seen my document will drop quality one step same as input to hot folder.
    Am not sure about this relate to abbyy engine or not ?

    Regards,
    James
    0
  • Avatar
    Vladislav Suvorov
    Hello again James,

    Regarding your question: FlexiLayout studio has the same Image Preprocessing and Show in color\black&white settings as FlexiCapture(first can be accessed on File->"Add images""Add images from folder" screens, second can be changed via Tools->Options->"Show image in black and white" checkmark.
    Sadly I am unable to give a more precise answer since I am not a developer and have no access to source codes or any kind of information regarding hidden Image Preprocessing algorithms.

    Best regards,
    Vladislav
    0
  • Avatar
    Vladislav Suvorov
    A small addition:
    Please use the following link
    https://abbyy.technology/en:featurescr:imaging
    to find more details on technologies which take place during OCR processing. Hope this would be helpful.

    Regards,
    Vladislav
    0
  • Avatar
    laptorkung
    A small addition:
    Please use the following link
    https://abbyy.technology/en:featurescr:imaging
    to find more details on technologies which take place during OCR processing. Hope this would be helpful.

    Regards,
    Vladislav



    Hi Vladislav,
    Thank you for all your reccommend and support.
    Right now I already solve my problem.
    The way is change script to FullColor. but in this case My team will discuss about size of file.
    I think first time my team focus on size of file but now user team focus on quality.

    I will study your recommend link.

    Regards,
    James
    0

Please sign in to leave a comment.