How to use web service to import images and get verification task in station ?

Hi all,

I refer the API sample(Processing Multiple Documents in One Batch) from development guide to develop a web service tool.

But, the different is I use advanced workflow instead of unattended like below:


In the project setup station or admin console, I can find the batch or task is running and enter the verification stage(state is display waiting).

But I can't get any task in queue when I open the verification station as senior verification operator.

I use the windows authentication with the same user both in web service and station, It seems no permission problem. Besides, use OpenSession with parameter (12,10)/(6,3).

Is there anything wrong or web service only can get verification task by itself?

Thanks in advance.

Was this article helpful?

1 out of 1 found this helpful



  • Avatar
    Adrian Enders

    I want to add to this. I believe that I am having the same problem. I can create batches using web services, but when I do I cannot see the batches in Verification (thick or thin client) as a task - they don't show up in the Queue. I can only see the batch in Verification in "Batch" view, not in the "Queue" view. I would like to solve this problem too.

    I had to use Hot Folders to import to get the documents to view in a queue. I would like to create batches in FC from the web services.

    I tried many different parameters for "OpenSession" as well - I could not find a combination that corrected this problem.

    I am on FC 12 R2.

    I am currently working on creating task to see if that solves the problem. No luck so far.

    I can tell you that I ran Fiddler and opened up Web Scanning and ran a trace while uploading a document. If I use web scanning I can see the tasks in Queues. Web scanning seems to use these same web service methods. According to Fiddler, it did so in the following order:






    [repeat] AddNewDocument()

    AddNewPage() [repeat]





    I noticed that web scanning never uses "AddNewImage()". I think you are working from the same example that I am. I think we are both trying to solve the same problem.


  • Avatar
    Adrian Enders

    Ivan, did you ever get a resolution to this?

  • Avatar


    Could you please make sure that the "allow web station" check mark is enabled?

  • Avatar
    Adrian Enders

    Yes, this is enabled. If I create a batch using Scan Station, I can view the tasks just fine. If I create the batch in the above way using API web methods, I cannot see the tasks.



  • Avatar

    Dear Adrian,

    Unfortunately, I still have the same problem and wait for response from Ekaterina or others.

  • Avatar
    Adrian Enders

    Ivan, I might have a resolution for you, thanks to a couple friends at ABBYY. For me this turned out to be the ownerId in the AddNewBatch method. The ownerId needs to be set to 0. I was setting it to the current logged in user. Once I set this to 0 (zero) the batches started showing up as tasks in Queues view.


Please sign in to leave a comment.