Community

OCR Cloud + iOS6 + Timeout

Hi,

I've downloaded the ocrsdkdemo example available on the website. I've launched it and used it prior the release of iOS 6 and it worked fine with the simulator.

Now that I've upgraded to iOS6 and XCode 4.5 I have the following issue:

  • With the JPG provided as a sample (137Kb) => Works
  • Using a 417Kb JPG => Get a time-out "Error - Network Connection Lost"

I didn't have any problem prior the update with this second JPG.

Any idea please ? Thanks for the help

0

Comments

2 comments

  • Avatar
    Dmitry Mesheryakov

    With these specific symptoms the likely explanation is that with a larger file the upload takes longer and a timeout occurs on a slow connection. The behavior change might be due to some subtle changes in the iOS runtime. The number one thing to check in such conditions is whether increasing the timeout on the client resolves this problem.

    0
  • Avatar
    fvives

    Yes, that was my assumption and from what I've read while searching on the web, it seems to be a common problem.

    The surprising part though is that I get the time-out after 2 or 3 seconds, which is kind of strange given that the default timeout value is supposed to be 60s. I've tried setting manually the timeout to a greater value but it doesn't change anything.

    0

Please sign in to leave a comment.