Missing sampleconfig.cs file from SDK samples Answered

The file included in the FlexiCapture Engine download file does not include the sampleconfig.cs file. Many of the sample won't compile without this file.

Please direct me where I can get this file.

Thanks, Chris




  • Avatar
    Oksana Serdyuk

    Have you done a standard development installation by clicking on setup.exe or have you copied the files from the distributive? The fact is that the SamplesConfig file is an automatically generated file during standard development installation.

    This file should look in the following way:

    using System;
    class FceConfig {
         // full path to FCE dll
         public const string DllPath = "C:\\Program Files (x86)\\ABBYY SDK\\11\\FlexiCapture Engine\\Bin\\FCEngine.dll";
         // Return full path to FCE dll
         public static string GetDllPath() {
            return "C:\\Program Files (x86)\\ABBYY SDK\\11\\FlexiCapture Engine\\Bin\\FCEngine.dll";
        // Return developer serial number for FCE
        public static string GetDeveloperSN() {
            return "********************"; //Here you should specify your serial number
        // Return full path to Samples directory
        public static string GetSamplesFolder() {
            return "C:\\ProgramData\\ABBYY\\SDK\\11\\FlexiCapture Engine\\Samples";

    and include the adapted license number of your program and path to FREngine.dll and to the Samples directory. It should be saved in the SampleConfig folder of your Samples directory: ...\ABBYY\SDK\11\FlexiCapture Engine\Samples\SampleConfig.

  • Avatar

    I did the standard installation but there is no samples folder in the installation folder. The folders I have in the path C:\Program Files (x86)\ABBYY SDK\11\FlexiCapture Engine\ are:

    • Bin
    • Data
    • Help
    • Installation Guide
    • USB Drivers
    • Wibu

    I didn't see an option to install samples during install. Did I miss something?

  • Avatar

    Oops, I see the path you in your code now. I see samples folder in that location. Thanks.


Please sign in to leave a comment.