Issues using service Answered

Hi All,

I have been having issues using the service, I get a NSURLErrorDomain -1012 so this meant little to me so I tried on a different phone and it was giving me the same error but more details in the log.  

CredStore - performQuery - Error copying matching creds.  Error=-25300, query={

    class = inet;

    "m_Limit" = "m_LimitAll";

    ptcl = htps;

    "r_Attributes" = 1;

    sdmn = "";

    srvr = "";

    sync = syna;




So I added the following to satisfy the keychain issue (can't copy credentials if not successful)


NSURLCredential *credential = [[NSURLCredential alloc]






    NSURLProtectionSpace *protectionSpace = [[NSURLProtectionSpace alloc]








    [[NSURLCredentialStorage sharedCredentialStorage] setDefaultCredential:credential forProtectionSpace:protectionSpace];


This still makes no difference.  So I tried the url in PostMan to see what went on it proved to me that the authentication pair was correct but whenever I tried to send it would pop up a credentials dialog box.


Any help would be gratefully received





Was this article helpful?

0 out of 0 found this helpful


1 comment

  • Avatar
    Oksana Serdyuk

    Hello Damien,

    Please sorry for delay. According to our database, you have managed to process some images successfully. Do we understand correctly that you have resolved the issue?

    If not, please specify some details:

    1) Could you please clarify if the issue occurs with our standard iPhone sample (where your Application ID and Application Password are specified)?
    2) Please send us the logs from any HTTP debugger. The logs should include the headers, the request content and the response from the service. It will allow us to see what requests do you send to the server and consult with our developers.



Please sign in to leave a comment.