Community

PIP install requests failing

When I perform a PIP install requests for requirements.txt it fails. Can you help with some guidance?

pip install -r requirements.txt
Collecting requests==2.18.4 (from -r requirements.txt (line 1))
  Could not find a version that satisfies the requirement requests==2.18.4 (from -r requirements.txt (line 1)) (from versions: )
No matching distribution found for requests==2.18.4 (from -r requirements.txt (line 1))

0

Comments

3 comments

  • Avatar
    Koen de Leijer

    Hi

    This has nothing to do with ABBYY, but with PIP itself, 2.18.4 is the latest version of "requests"
    are you using Python 2 or Python 3? Is your internet connection working? What OS are you working on? Are you using pypi.org or  legacy.pypi.org? what version of PIP is installed?
    Please post your complete error-log / console-output

    Best regards
    Koen de Leijer

    0
  • Avatar
    Umesh Lakshman
    umesh/Python$     pip install -r requirements.txt
    Collecting requests==2.18.4 (from -r requirements.txt (line 1))
      Could not find a version that satisfies the requirement requests==2.18.4 (from -r requirements.txt (line 1)) (from versions: )
    No matching distribution found for requests==2.18.4 (from -r requirements.txt (line 1))
    umesh/Python$     pip install requests==2.18.4
    Collecting requests==2.18.4
      Could not find a version that satisfies the requirement requests==2.18.4 (from versions: )
    No matching distribution found for requests==2.18.4
    
    umesh/Python$ pip --version
    pip 7.1.2 from /Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/site-packages (python 3.4)
    umesh/Python$ python -V
    Python 2.7.10
    umesh/Python$ sw_vers
    ProductName:	Mac OS X
    ProductVersion:	10.13.4
    BuildVersion:	17E202
    
    Internet connection works. how would I know if I am using pypi.org or legacy.pypi.org? New to this domain and hence if there is an very rudimentary step by step guide to get this going, that would be great. thanks again for helping look into this.
    

     

    0
  • Avatar
    Koen de Leijer

    Hi

    It seems like you have a mixup of Python 2.7 and Python 3.4

    An important note from the requests-library website:
    The use of Python 3 is highly preferred over Python 2. Consider upgrading your applications and infrastructure if you find yourself still using Python 2 in production today. If you are using Python 3, congratulations — you are indeed a person of excellent taste. —Kenneth Reitz

    Also consider using virtualenv(wrapper) and if you do not really need Python2, just use Python3.
    Plus, your version of pip is very outdated.

    With one of these two manuals you should be able to install all the latest & greatest on OSX:
    https://www.digitalocean.com/community/tutorials/how-to-install-python-3-and-set-up-a-local-programming-environment-on-macos
    http://www.marinamele.com/2014/07/install-python3-on-mac-os-x-and-use-virtualenv-and-virtualenvwrapper.html
     
    Best regards
    Koen de Leijer

    0

Please sign in to leave a comment.