Solved: Error creating an Application Server session: Not enough rights on the Application Server.” Answered

Hi All,

Just thought id share a solution to an issue I had today moving a workgroup FC12 server into a domain.

After joining the server to the domain. I noticed the processing service would not start.

Reapplying Logon As: network service  under the windows service 'FlexiCapture Processing Server'  (Tip: you dont type any password) this got the service starting but then we noticed that the server itself was showing as paused within the Processing Server Application - You could start it manually but it would pause again after a few seconds.

The windows event log showed a basic error but not much to go on, enabling logging didnt give much more either

“FlexiBr: Processing Server restart: Error creating an Application Server session: Not enough rights on the Application Server.”

I checked that the service had all the right permissions on the hot folder drives and shares.  Checked IIS authentication settings (saw this mentioned on here on another post) didnt work so reverted.

After much troubleshooting and again checking all file permissions I found under Server Monitoring & Administration the section for users accounts there was a new user account that was DOMAINNAME\COMPUTERNAME$

It looks like when the machine joined the domain and the service started as network service it created a new internal abbyy user DOMAINNAME\COMPUTERNAME$. This user by default did not have the processing server role assigned.  ( I was able to see there was the origin account called WORKGROUP\COMPUTERNAME$ that did have this role) 

Hoping to pay it forward and that this helps someone else in the future.



Was this article helpful?

4 out of 4 found this helpful



  • Avatar
    Adrian Enders

    Hi Phil, I noticed this too. When one of the FC services first attempts to connect to FC App Server, if that account (the account running the service) is not already a user then FC automatically adds that account to the "Users" group with no permissions. I believe the same thing happens when someone uses the "Registration" link on the web login page. The operator is added to "Users" with no specific permissions.


    Thanks for the note!

  • Avatar
    Ivan Diaz

    Thanks for this! I had exactly the same issue.


Please sign in to leave a comment.