Community

In Abbyy flexi studio the layout cannot pre recognize the invoices properly

Abbyy cannot pre recognise the invoice in the layout studio even though the invoice quality is good because when i anchor the address in project setup station abbyy is extracting the address but in studio it is not extracting any values moreover it cannot recognize the invoice properly.

for more reference i have attached the screenshot

you can see the yellow lines ,instead of extracting the whole field it is recognizing only the small line.

Thanks,

1

Comments

7 comments

  • Avatar
    Scott Chau

    Please show me the tree of hypothesis.  Basically the green/orange/red circle.  That should tell me where its stopping then we can track from there.

    1
  • Avatar
    Rahul Kapoor

    This could be because of the text layer present on the document is not same as the visible text. To fix this, while pre-recognizing use OCR to recognize the text instead of using the text layer.

    Hope this resolves your query!

    Regards,
    Rahul Kapoor
    www.linkedin.com/in/rahulkapoor309/

    0
  • Avatar
    Scott Chau

    Ziplo,

    Rahul is probably correct.  Here is the screenshot of the setting you need to change

    0
  • Avatar
    Aravind

    Yes when i change to OCR it is properly highlighting the element. now the thing is when i match the layout no element is getting highlighted or matched instead it is showing no region is found ,but when i individually test the element it is highlighting the region.

    Thanks,

    0
  • Avatar
    Rahul Kapoor

    This could be because some elements are not properly configured which results in the whole layout not getting matched. Check the tree of hypothesis at the bottom to figure out where the chain in breaking. Or you can try disabling some elements and match the layout to figure out the element that is causing the issue.

    Regards,
    Rahul Kapoor
    www.linkedin.com/in/rahulkapoor309/

    0
  • Avatar
    Aravind

    Hi Rahul and Scott Chau,

    this is the log message as i said in the above message when i tried element separately and test element its working but when i match it, it shows this log error and no elements are getting matched.

    0
  • Avatar
    Aravind

    Hi Rahul and Scott Chau,

    Ya it's working for me, thank you guys. I thought in forum no one will respond but you both gave your valuable time for my question .Thank you so much ,the only issue i face now is Vendor name and address ,can you guys help me to solve this also ,i will explain in detail: 

    We can map regions in studio but here the vendor name and address is recognized by abbyy in project setup station by default so even though the address is available in invoice, abbyy extract the complete address or name that includes labels(logo) of each vendor because of this it results in mixing up with unwanted letters and missing specific name of the vendor.So as specific name is not extracted the address field is alos getting empty.

    We make more validations based on vendor name this is a major issue i'm facing.

    Suggestion:

    • Vendor name and address is given properly in Remit To address is there any way to make abbyy to read name and address from Remit To address instead of label and map that with dataset.

    Note:

    1.We map vendor name and address from dataset so we cannot create regions for that.

    2.Invoices with no labels(logo) for vendor i.e the vendor name is in single line, Abbyy is extracting proper vendor name.

    Thanks guys,

    Be safe

    0

Please sign in to leave a comment.