Сообщество

Passing username and password variables to web capture station via URL

Hi All,

Does anyone know whether its possible to pass login details to the 'Web Capture Station' login form via a URL or similar?

Just trying to automate the login process for the user.

Many thanks

Richard

Была ли эта статья полезной?

Пользователи, считающие этот материал полезным: 0 из 0

Комментарии

Комментариев: 22

  • Avatar
    Sushi
    richfish,

    Via URL is not possible. Web Service yes. If you are trying to do some sort of SIngleSignOn, then the best option is to upgrade to the latest version of FlexiCapture 11. It has the option to detect the windows auth so that they don't have to login. Its in the most current release of FlexiCapture 11. Basically you need to make some changes to the web.config file and add the "...Login.asp?windowsauth=true" to the URL
    0
  • Avatar
    Samir

    Hi,

    Can you give the steps to config SSO?

    Thanks,

    0
  • Avatar
    Scott Chau

    Samir,

    For the web stations, it just adding a "winauth" to the URL.  So if the Admin and Monitoring console was 


    http://localhost/FlexiCapture12/Monitoring

    then use

    http://localhost/FlexiCapture12/Monitoring/winauth

    0
  • Avatar
    Samir

    Hi Scott,

    Even if i add winauth to the URL, it redirects to normal login page only. What changes i have to do and where to get this? Also what will happen after adding winauth to URL?

    Thanks,

     

    0
  • Avatar
    Scott Chau

    What version of FlexiCapture are you using?

    0
  • Avatar
    Samir

    Hi,

    We are using FC12 3063 build no. Do we have check settings somewhere?

    Thanks,

     

    0
  • Avatar
    Scott Chau

    I think you have some issue with your IIS setting or your user name isn't correct in the Users section.  If you look in the users, is your name listed correct and have the correct permission.  Your user name should be listed as "domain\username" or "computername\username"

    If its an IIS issue, you should create a support case and they can do a remote call to check your settings.

    0
  • Avatar
    Samir

    Hi Scott,

    Do i need to change any settings in IIS for flexicapture12 (Login,monitoring) etc, any idea?

    Yes, my username is not as domain\username, its normal username only.

    Thanks,

     

    0
  • Avatar
    Scott Chau

    Samir,

    You need to change it in your FlexiCapture user login name.  .

    0
  • Avatar
    Samir

    Hi Scott,

    I Changed mu username ComputerName/UserName and  by adding winauth to URL, it was working without logging in. But when i cleared cache/history of the browser, i have to login again despite adding winauth to URL. What can be done to allow always direct login without entering anything.

    Thanks,

    Samir

    0
  • Avatar
    Scott Chau

    Your slash is the wrong direction.  It should be ComputerName\UserName not ComputerName/UserName

    If you are using winauth, it should ever ask for the password unless you have some weird setting.  If changing the slash doesn't work, create a support case so they can do a webinar meeting and go over your setting.

    0
  • Avatar
    Samir

    Hi Scott,

    I added username as compname\username. Now by adding winauth to URL was able logged in automatically (without credentials). But my question is, if we clear cache/history, it will directed to login page even if we add winauth to URL. Can we do any settings so that it will always get logged in even if cache has been cleared?

    Thanks,

     

    0
  • Avatar
    Scott Chau

    Even if you clear cache, it should take you to the login page unless your URL is the login page.  For example in my case, if I use the url Select project and role  It takes me to the web verification station directly.

    0
  • Avatar
    Samir

    Hi Scott,

    Yes, if i clear cache, it takes to me log in page , where i would have to enter credentials (where winauth is added to URL).

    What need to do when ,after clearing cache and adding winauth to URL , will take me to web station directly?

    Thanks for info,

    Thanks,

    0
  • Avatar
    Scott Chau

    That's strange, it shouldn't take you to a login page.  When you say login page, are you talking about FlexiCapture login page like the screenshot?

     

    0
  • Avatar
    Samir

    Hi Scott,

    Yes, End user is using their client specific URL and not localhost as application server is at diff location. https://CleintURL/flexicapture12/Login/winauth gives following screen to user. What to do, so that end user using web station can log in directly by adding winauth?

    0
  • Avatar
    Scott Chau

    That screenshot you provided is NOT an ABBYY login.  That looks like something that is coming from your OS or Browser.  Its probably a setting in your browser or OS security.  You might need to do some research on that since I'm not having that issue so I cant troubleshoot it on my end. 

    0
  • Avatar
    Samir

    Hi Scott,

    I also get following login screen without winauth in URL.

    But when winauth is added, i get the one which i sent in previous message.

    Kindly guide.

    Thanks,

     

     

     

    0
  • Avatar
    Scott Chau

    That screenshot is correct.  Without Winauth, it won't use the windows authentication.  It will use the FlexiCapture authentication and you will need to put in those credential.  

    0
  • Avatar
    Scott Chau

    Samir,

    Did some googling and found some information.  Looks like what ever browser you are using is not passing the windows authentication over when you use the wiinauth.  In the case of FireFox, you need to add the URL.  See this link.  https://docs.helloid.com/hc/en-us/articles/115002887174-How-to-allow-NTLM-Windows-Authentication-in-Firefox

    Other web browser you will need to google and see how to pass the authentication.  

    0
  • Avatar
    Samir

    Hi Scott,

    Correct. Without winauth, it is using flexicapture authentication. By adding winauth, asking for credentials in chrome and edge. Do you know any settings  to avoid this?

    Also i was looking into IIS, does this matter?

    Thanks,

    0
  • Avatar
    Scott Chau

    Samir,

    Those setting look fine.  The issue is your browser.  See message above.  You might need to google how to enable windows authentication for your browser.  The link I provided above showed how to do it for FireFox.

    0

Войдите в службу, чтобы оставить комментарий.