Symptoms
The document is being matched correctly in FlexiLayout Studio, but when it's processed in FlexiCapture, it is recognized as an Unknown Document.
Cause
The usual causes are the image quality of the used samples, unreliable elements used as Header, Footer, or other Required Elements, and different Image Processing settings in FlexiLayout Studio and FlexiCapture.
Resolution
In case you encounter a situation when in FlexiCapture the document is not being matched to the Document Definition based on FlexiLayout, it is necessary to remember the measures that can make the results better:
- Use high-quality images whenever possible.
- In FlexiLayout, use reliable objects of good quality: keywords, separators, etc.
- Make sure that the Image Processing settings are as same as possible between the two.
FlexiCapture:
FlexiLayout Studio:
- Always check the hypothesis tree in FlexiLayout Studio and make sure there are no branching, empty, or unreliable (yellow) elements.
- In case there is a multi-page document in FlexiLayout Studio, make sure the Header and Footer are set correctly and the reference document is assembled correctly (indicated with a green and blue line):
- Make sure to always keep the number of Required elements in FlexiLayout as low as possible, because their excessive amount may cause problems such as the inability to match.
Please see the following article to learn more about the process of matching multiple FlexiLayouts
Additional information
Additional articles to refer to in case of the difference in FlexiLayout and FlexiCapture recognition results:
- How to examine situations where matching results are different in FlexiCapture and FlexiLayout Studio
- Unknown document status even though it was correctly matched in FLS. FlexiCapture cannot match the document
- What would cause documents not to be recognized the same in FlexiLayout Studio and document definition in Project Setup Station
- Characters are not captured or captured on the incorrect spot on the page