Web services API shows an error: Unable to access the directory <path>.Please make sure that the directory exists and that you have sufficient permissions to access it.

Symptoms

When processing a document using ABBYY FineReader Server Open API, the import fails with the  error message:

"Unable to access the directory <path>. Please make sure that the directory exists and that you have sufficient permissions to access it. For instructions on setting up access permissions required by the ABBYY FineReader Server Open API, please refer to the documentation."

InZx5Bug0o.png

Cause

Usually, the following error appears when the user account under which the ABBYY FineReader Server 14 Application Pool is launched doesn't have sufficient read/write permissions to the following folders

Resolution

  1. The recommendation is granting all permissions to the user that runs the Application pool as well as to the user that runs Server Manager and Processing Station Windows services.
    Please refer to the following article that contains instructions on how to change the user or grant  access: Access permissions required by the Open API
    Additionally, in case Read&Write permissions are granted for the user that runs Application Pool and FineReader Server Services, but the error persists, add Full control for Everyone (For directories mentioned above)

  2. In case all permissions are correctly set but the issue still occurs even with Full control for Everyone  navigate to C:\Program Files\ABBYY FineReader Server 14.0\FineReaderServerWS\Web.config and change the following line from:
     <directFileAccess enabled="false" />
    to
    <directFileAccess enabled="true" />

    Please note: enabling this option may introduce a security vulnerability
    unless proper access control is used for the application pool identity account.

    This option is disabled by default.
    (Recommendation is performing the first step (granting all permissions to the folder/user) before changing the directFileAccess value to "true")

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.