FlexiCapture 12 not working after upgrading OS to Windows Server 2022

Symptoms

Getting this error message:

Cannot connect to <application server> (error code: HTTP 500 Internal Server Error)

Failed to get SSO providers list. Cannot connect to <application server> (error code: HTTP 500 Internal Server Error

 

Cause

When upgrading the Operating System, some of its components are also updated and modified. Some of which but not limited to are:

 

Service Account switches to default (Network Service)

IIS removing Application Pools

OLE DB Driver compatibility

 

Resolution

  1.  Run a Repair Installation of FlexiCapture
  2. Create a UDL test connection to the Database
    1. Open a Notepad and save it as .udl
    2. Open this file by double-clicking on it and it will show this similar image:
    3. Go to Provider tab > Select Microsoft OLE DB Provider for SQL Server then click Next.
    4. This will take you to the Connection Tab, where you'll need to fill in the information required.
    5. Once done, click test connection.
  3. If the connection has succeeded, open the file in Notepad to see the connection string and get the provider used. 
  4. Update the FlexiCapture Server connection string.
    1. Go to C:\inetpub\wwwroot\FlexiCapture12\Server
    2. Open Web.config with Notepad or any text editor.
    3. Update the provider in the connection string, see this example below:
      From
      <connectionStrings><add name="FlexiCapture12ConnectionString" connectionString="Provider=SQLNCLI11;Data Source=(local)\SQLEXPRESS_TEST;Initial Catalog=CATALOG;Trusted_Connection=yes" /></connectionStrings>

      To
      <connectionStrings><add name="FlexiCapture12ConnectionString" connectionString="Provider=SQLOLEDB.1;Data Source=(local)\SQLEXPRESS_TEST;Initial Catalog=CATALOG;Trusted_Connection=yes" /></connectionStrings>
  5. Validated the Services of FlexiCapture are still running with the right account.
    1. Open the Run command, Windows key + R, or Click the Windows Key and type in Services.msc
    2. Look for FlexiCapture Services and check if it still running
    3. Check if the "Log On As" Account is the correct one. See the image below for reference:

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