Symptoms:
Your IMAP import profile is not importing any images. You can open your Processing Server -> Tasks and check if there are failed import tasks. When you double-click on the failed task there is a short log that says:
Failed to open the file 'file_path' using embedded Office application. Exit code: 4.
Cause:
All import tasks are performed by the user, under which the Processing Station Service is running. By default, it is a Network Service account. This user doesn't have enough permissions to perform a task.
Resolution:
- Click . The Computer Management window opens.
- Click . The list of groups opens.
- Double-click the Performance Monitor Users group. The Performance Business Monitor Users Properties window opens.
- Click Add. The Select Users or Groups window opens.
- In the Enter the object names to select field, enter the user account name to whom you want to assign permissions, and then click OK.
- Click Apply, and then click OK.
- Repeat steps 3-6 for the Performance Log Users group.
Comments
4 comments
Sharmila S Alanka (ext)
I have tried the same, but still it is not working for me.
It is the same error Failed to open the file 'doc path' using Microsoft Office. Exit code: 4.
can you help me here
Sharmila S Alanka (ext)
the same document is getting processed in TEST environment but not in PROD enviornment
Maksym Diachenko
Sharmila, please make sure that you have the same builds of MS Office installed on the test and prod. If they are but the issue still occurrs- please submit a support ticket with Windows Event Logs, sample file, and FC Event Log from the Administration and Monitoring Console.
Sharmila S Alanka (ext)
HI Makysm,
Thank you for the response.
We are using ABBYY Flexi Capture - 12.0.3.4093 in both TEST and PROD.
We do not have MS office installed in both TEST and PROD servers. DOC files were processing till two weeks back.
The file which was processing in TEST is not processing in PROD. So installed MS Office version 2006 64bit in PROD servers but still files are not processing. Changed the format of the DOC file and tried, still no use
Already raised a ticket to ABBYY and gave all the required logs and exported the project file as well. It was running fine from their side and said no issues with the project and the DOC file.
ABBYY team responded the below
If manually added documents would be processed without any issues please address the case to the IT department of your organization.
And they found 2 error withing the logs
ABBYY FlexiCapture Web Services: Requested operation requires an OLE DB Session object, which is not supported by the current provider.
ABBYY FlexiCapture Web Services: TCP Provider: Timeout error [258].
When trying to investigate the same,
Regarding the OLEDB session everywhere I could see some VB connection string to connect to database but in ABBYY we have created Database from Admin console and no where we used the connection strings. Not sure if ABBYY uses the connection string internally somewhere. If so need help in that.
On further investigation and research found that ABBYY could not open the DOC file and says access denied. When got the logs from ABBYY Processing station, found the below error.
It says faulting application and DLL. There can be a chance that some .Net framework or some DLL would have corrupted as the files were processing earlier and that is why ABBYY cannot take/open the files. But couldn’t figure out which one is exactly used by ABBYY.
Need some insight here go progress further
Thanks in advance,
Sharmila.
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