FlexiCapture 12: Error on IMAP import: "Failed to open the file using embedded Office application. Exit code: 4."

Symptoms:

Your IMAP import profile is not importing any images. You can open your Processing Server -> Tasks and check if there are failed import tasks. When you double-click on the failed task there is a short log that says: 

Failed to open the file 'file_path' using embedded Office application. Exit code: 4.

Cause:

All import tasks are performed by the user, under which the Processing Station Service is running. By default, it is a Network Service account. This user doesn't have enough permissions to perform a task. 

Resolution:

  1. Click Start > Control Panel > Administration Tools > Computer Management. The Computer Management window opens.
  2. Click System Tools > Local Users and Groups > Groups. The list of groups opens.
    mceclip1.png
  3. Double-click the Performance Monitor Users group. The Performance Business Monitor Users Properties window opens.
    mceclip3.png
  4. Click Add. The Select Users or Groups window opens.
    mceclip2.png
  5. In the Enter the object names to select field, enter the user account name to whom you want to assign permissions, and then click OK.
    mceclip4.png
  6. Click Apply, and then click OK.
  7. Repeat steps 3-6 for the Performance Log Users group.

 

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Comments

4 comments

  • Avatar

    Sharmila S Alanka (ext)

    I have tried the same, but still it is not working for me.

    It is the same error Failed to open the file 'doc path' using Microsoft Office. Exit code: 4.
    can you help me here

    0
  • Avatar

    Sharmila S Alanka (ext)

    the same document is getting processed in TEST environment but not in PROD enviornment

    0
  • Avatar

    Maksym Diachenko

    Sharmila, please make sure that you have the same builds of MS Office installed on the test and prod. If they are but the issue still occurrs- please submit a support ticket with Windows Event Logs, sample file, and FC Event Log from the Administration and Monitoring Console. 

    0
  • Avatar

    Sharmila S Alanka (ext)

    HI Makysm,

    Thank you for the response.

    We are using ABBYY Flexi Capture - 12.0.3.4093 in both TEST and PROD.

    We do not have MS office installed in both TEST and PROD servers. DOC files were processing till two weeks back.

    The file which was processing in TEST is not processing in PROD. So installed MS Office version 2006 64bit in PROD servers but still files are not processing.  Changed the format of the DOC file and tried,  still no use

     

    Already raised a ticket to ABBYY and gave all the required logs and exported the project file as well. It was running fine from their side and said no issues with the project and the DOC file.

    ABBYY team responded the below

    If manually added documents would be processed without any issues please address the case to the IT department of your organization.

    And they found 2 error withing the logs

     

    ABBYY FlexiCapture Web Services: Requested operation requires an OLE DB Session object, which is not supported by the current provider.

    ABBYY FlexiCapture Web Services: TCP Provider: Timeout error [258].

     

     

    When trying to investigate the same,

    Regarding the OLEDB session everywhere I could see some VB connection string to connect to database but in ABBYY we have created Database from Admin console and no where we used the connection strings. Not sure if ABBYY uses the connection string internally somewhere. If so need help in that.

     

    On further investigation and research found that ABBYY could not open the DOC file and says access denied.  When got the logs from ABBYY Processing station, found the below error.

    It says faulting application and DLL. There can be a chance that some .Net framework or some DLL would have corrupted as the files were processing earlier and that is why ABBYY cannot take/open the files. But couldn’t figure out which one is exactly used by ABBYY.

     

    Log Name:      Application
    Source: Application Error
    Date: 12.05.2021 12:04:52
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: dehensv-roprs01.henkelgroup.net
    Description:
    Faulting application name: FlexiEx.exe, version: 12.0.3.4093, time stamp: 0x5fdb5125
    Faulting module name: controller.dll, version: 12.0.3.4093, time stamp: 0x5fdb5205
    Exception code: 0xc0000005
    Fault offset: 0x0000000000070786
    Faulting process id: 0x43d8
    Faulting application start time: 0x01d747161100e47f
    Faulting application path: E:\ABBYY SOFTWARE\Program Files\ABBYY FlexiCapture 12 Stations\FlexiEx.exe
    Faulting module path: e:\abbyy software\program files\abbyy flexicapture 12 stations\controller.dll
    Report Id: f3d52207-1500-4817-8943-edfe02dd4213
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2021-05-12T10:04:52.584611700Z" />
    <EventRecordID>184539</EventRecordID>
    <Channel>Application</Channel>
    <Computer>dehensv-roprs01.henkelgroup.net</Computer>
    <Security />
    </System>
    <EventData>
    <Data>FlexiEx.exe</Data>
    <Data>12.0.3.4093</Data>
    <Data>5fdb5125</Data>
    <Data>controller.dll</Data>
    <Data>12.0.3.4093</Data>
    <Data>5fdb5205</Data>
    <Data>c0000005</Data>
    <Data>0000000000070786</Data>
    <Data>43d8</Data>
    <Data>01d747161100e47f</Data>
    <Data>E:\ABBYY SOFTWARE\Program Files\ABBYY FlexiCapture 12 Stations\FlexiEx.exe</Data>
    <Data>e:\abbyy software\program files\abbyy flexicapture 12 stations\controller.dll</Data>
    <Data>f3d52207-1500-4817-8943-edfe02dd4213</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    </EventData>
    </Event>

     

    Need some insight here go progress further

     

    Thanks in advance,

    Sharmila.

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