"The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing" when installing FineReader 14 update

Symptoms

When installing updates in FineReader 14, the following error message appears:

The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch.

Resolution

In order to resolve the issue, please try to follow the steps below:

  1. Repair FineReader 14 as described in the article: Repairing FineReader.
    After the repair, try to install the updates through the Help menu > Check for Updates.
  2. If the issue has not been resolved, try installing the latest version of FineReader 14 over the installed version:
    1. Download the distribution kit of the latest version.
    2. Extract the files to the temporary folder (by default C:\temp\FR14).
    3. Run the Setup.exe
    4. After the installation, restart the computer.
    5. Check whether no updates are available by going to the Help menu > Check for Updates.
  3. If repairing the program did not fix the issue, perform a reinstallation of FineReader 14 as follows:

    1. Uninstall the program as described in the article: How to completely remove ABBYY FineReader? 
    2. Install the program using the distribution kit of the latest version of the program.

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.

Recently viewed