現象
ライセンスサーバを搭載したマシンとは異なるマシンに検証ステーションをセットアップしました。
検証ステーションを起動すると、次のエラーが発生して起動できません。
「(ライセンスサーバを搭載したマシンの IPアドレス)上のABBYY製品ライセンスサービスとの通信エラーが発生しました。不明なエラーです。エラーコード:0x0 Diagnostic Message: Connect to server timeout.」
この事象が発生した際の切り分けのための確認方法と、対処について教えてください。
原因
この現象は、ライセンスサーバを搭載したマシンと、検証ステーションをセットアップした異なるマシンとの間での通信に何らかの問題がある場合に発生します。ライセンスサーバを搭載したマシンとの間ではポート 3020 を介した接続を許可する必要がございます。
解決
検証ステーションをセットアップしたマシン上で PowerShell を起動して、以下のコマンドを実行して、ライセンスサーバとポート 3020 を介したネットワークの接続性を確認します。
Test-NetConnection -ComputerName "(ライセンスサーバを搭載したマシンの IPアドレス)" -port 3020
以下のように TcpTestSucceeded : False が返されていましたら、ポート 3020 を介した接続を許可するようネットワーク設定を変更してください。。
Test-NetConnection -ComputerName "ComputerName" -port 3020
ComputerName : ComputerName
RemoteAddress : ***************
RemotePort : 3020
InterfaceAlias : イーサネット
SourceAddress : ***************
TcpTestSucceeded : False
ネットワーク設定の変更後に TcpTestSucceeded : True が返されていましたら、検証ステーションをもう一度、起動してみてください。
または、ネットワークの設定により必要な接続が不可能であれば、検証ステーションの代わりにリモート検証ステーションを試しください。リモート検証ステーションの利用にはHTTP上のアプリケーションサーバーとの接続のみが必要です。
コメント
0件のコメント
サインインしてコメントを残してください。