現象
HotFolder からのファイル読み取りが動かず、処理サーバモニタで確認すると処理サーバも処理ステーションも開始できません。
原因
いくつか確認すべき点があります。
- もっとも端的な原因として、サービスの実行ができない、または停止していると発生します。
- 処理サーバモニタでの処理サーバのプロパティでアプリケーションサーバの URL に間違いがあります。
- 処理サーバーのWindowsサービスを起動するユーザーはFlexiCaptureで[処理サーバ] のロールを持っていません。
解決
- サービスの実行アカウントを Network Service(デフォルト)、または管理者権利のあるドメインユーザーにしてからサービスを開始します。
ABBYY FlexiCapture 12 Processing Server
ABBYY FlexiCapture 12 Processing Station
また処理サーバや処理ステーションのトレースログを取得すると原因を示す痕跡が残されていることがあります。 - 処理サーバモニタで、処理サーバのプロパティを開いて、アプリケーションサーバの URL を確認します。
[処理サーバのトレースログを書く] にチェックマークを付けて [OK] をクリックします)
トレースログは「%ProgramData%\ABBYY\12.0\FlexiBr[Svc]\Logs」フォルダに保存されています。
トレースログに次のような「 http://********** に接続できません(エラーコード: (HTTP 401, 18, 0))」というエラーが記録されているか確認します。
記録されている場合は、以下の点を確認します。
ちなみに HTTP 401 の有効な認証資格が不足していることに起因して発生している可能性が高いです。
401 Unauthorized - PowerShell コマンドレットを用いた接続確認(すべて True である必要あり)を行います。アプリケーションサーバとの接続では、ポート 80 と 443 を介した接続が必要です。
Test-NetConnection -ComputerName "アプリケーションサーバのアドレス" -port 443
Test-NetConnection -ComputerName "処理サーバのアドレス" -port 10024
Test-NetConnection -ComputerName "ライセンスサーバのアドレス" -port 3020 - アプリケーションサーバでの UAC (ユーザー アクセス コントロール) 無効化を行います。
FlexiCaputre 12 自体は、ポート遮断や疎通ブロックの機能は有しておりませんので関係するすべてのマシンの Windows OS の UAC (ユーザー アクセス コントロール) を無効にします。 - 双方のマシンでウイルス対策ソフトウェアでの処置を確認して、適宜で必要な設定を施します。
合わせてマシン上のすべてのウイルス対策ソフトウェアでのライブスキャンをインストール中は、オフにすることをお勧めします。
それでも改善がされません場合は、以下のプログラムはスキャンの対象から外すように設定してください。
FlexiBrSrv.exe
FlexiBR.exe
FlexiCapture.exe - FlexiCapture 12 サーバ上で管理およびモニタリングコンソールを開いて [設定] > [ユーザ] を展開して、処理サーバの起動を試みているアカウントを探してください。
そのアカウントに [処理サーバ] のロールが設定されていることが必要となります。
- 次のフォルダにセットアップの間だけでも共有アクセスで読み込みと書き込みを許可してみてください。
C:\inetpub\wwwroot - 対象のマシンはアプリケーションサーバで、当該アカウントと Everyone アカウントが対象です。
セットアップに成功しましたら、設定を元に戻して問題ありません。 - Internet Information Service (IIS) の再起動を行います。
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