Symptoms
Cannot open FlexiCapture 12 applications, receiving the error:
Cause
Not all components are configured correctly, or servers with FlexiCapture 12 components cannot reach each other.
Resolution
- Make sure that the Licensing Service is running on the server.
- Go to Control Panel → Administrative Tools → Services;
- Select necessary Licensing Service: Licensing Service or ABBYY FlexiCapture 12 – Licensing Service;
- Press “Stop the service” and then “Restart the service”.
- Check if all settings for the Licensing Service are correct (see “Help → Distribution → Activating the Library → Installing Licensing Service”). Try to set or change the port number in the network settings of the LicensingSettings.xml both for the server station and for the workstation manually:
- Change LicensingSettings.xml for Server:<?xml version="1.0" encoding="utf-16"?>
<LicensingSettings xmlns="http://www.abbyy.com/Protection/LicensingSettings">
<LocalLicenseServer>
<ConnectionProtocol ProtocolType="TCP/IP" EndPointName="3020" />
<EnableIKeyLicenses Enable="no" /> "no" - if you use software license, "yes" - if you use USB protection key
</LocalLicenseServer>
</LicensingSettings> - Change LicensingSettings.xml for WorkStation:
<?xml version="1.0" encoding="utf-16"?>
<LicensingSettings xmlns="http://www.abbyy.com/Protection/LicensingSettings"><LicensingServers>
<MainNetworkLicenseServer ServerAddress="127.0.0.1" ProtocolType="TCP/IP" EndPointName="3020" />
</LicensingServers>
</LicensingSettings>
- Change LicensingSettings.xml for Server:<?xml version="1.0" encoding="utf-16"?>
- Nothing like closed ports or insufficient user rights prevents Licensing Service’s appropriate work. Check if the 3020 port number is opened from the server station to the client workstation:
-
Check if you have the telnet installation on the workstation:
- Pass to Control Panel → Programs and Features.
- Press the «Turn Windows features on or off» on the left menu.
- Select the «Telnet Client» checkbox in the Windows Features dialog box.
- Press the «OK» button.
-
Open the command line on the workstation and launch the following command: telnet 127.0.0.1 3020.
- If there occurs the error message «Could not open a connection to the host, on port 3020: Connect failed» in the command line, therefore, the port 3020 is closed on the server station.
- If there occurs the empty console, therefore, the port 3020 is opened and available on the server station.
-
- Probably the FlexiCapture 12 and License Service are from the different distribution packages? If yes, try to reinstall FC on the computer, where you receive the error message “RPC-Server is unavailable”.
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