Image Import\Export fails when custom batch types are used: "Access denied. Contact your Administrator"

Symptoms

Processing Station Task logs contain similar messages:

Access denied. Contact your Administrator.
The attachment files '***.pdf' of the message mail message (date: ***) from '*** <***>' with subject '***' have not been processed.
The message mail message (date: ***) from '*** <***>' with subject '***' has been moved to 'Exceptions'.
The task {5BC65FB1-5C33-46E0-A1E5-16C6DE607B05} failed after its non-recurrent subtask failed
Internal program error: E:\TfsBuildAgent\_work\1\s\Build\FlexiCapture\Controller\Enterprise\EnterpriseTask.cpp, 903.

 

When navigating to the PrincipalPermission table of the FlexiCapture database, the record with the RoleType = 11 (Processing Station) has a BatchTypeId value = 0.

Cause

Insufficient permissions granted to the Processing Station user.

BatchTypeId corresponds to the entry identifier in the BatchType table:

  • "0" means permissions are granted for the "Default" batch type (project properties);
  • "Null" means that permissions are granted for all batch types.

Resolution

Before the next steps, it is highly recommended to perform the database backup.

Use the following query to replace 0 with NULL for the Processing Station role type only. 

UPDATE [FC_database].[dbo].[PrincipalPermission]
SET BatchTypeId = NULL
WHERE RoleType=11;

Please note that the "FC_database" must be replaced with the FlexiCapture database name in the setup.

After the modification is done, try importing documents one more time.

Additional information

Create a Full Database Backup (learn.microsoft.com)

Creating an ABBYY FlexiCapture backup

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.