Error during installation: To continue installation of the Application Server component, please install Microsoft .Net Core 3.1 (or above)

Symptoms

The following message is continuously shown when trying to install server components of FlexiCapture 12 Distributed on Release 4 Update 2 (builds 12.0.4.803-12.0.4.857) even if Microsoft .Net Core 3.1 is installed:

To continue installation of the Application Server component, please install Microsoft
.Net Core 3.1 (or above) - Windows Server Hosting module. You can find this module available
in the External Components section of this distributed kit, or download it from microsoft.com
website

Cause

During the installation, a ..\Servers x64\Bin\Support\CheckIisAspNetCoreReady.ps1 script file from the distribution package is launched. The preset condition inside the script is causing the script check to fail.

Resolution

  1. Check if the .Net Core is installed in the Apps & features:
  2. If so, copy all the content of the installation distribution image, i.e. ABBYY_FlexiCapture12_Distributed_R4Ux_12.0.4.8xx.iso, to a separate folder.
  3. Edit the CheckIisAspNetCoreReady.ps1 script located under the path …<FOLDER NAME>\Servers x64\Bin\Support so that the code lines below:
    if( !$aspNetCoreModule ) 
    {   
      Exit 1;  
    } else {
      Exit 0;
    }
    will be substituted with the following one:
    if(true) 
    {      
    Exit 0;

    }
    As a result, the script will look as in the screenshot below:

  4. Save the modified script.
  5. Launch the installation Autorun from the local folder, where all the files were copied.

Note: If CheckIisAspNetCoreReady.ps1 does not exist, please try to download the distribution kit again and run an installation from scratch.

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Comments

10 comments

  • Avatar

    Russell Kent

    We have 12R4U3 (12.0.4.979) but still have this problem. And the workaround does not work because no such "check*" Powershell script exists in the ISO. See case #574934

    0
  • Avatar

    Andras Nagy

    Thank you for the info Russel! Unfortunately I am stuck as well because of this problem. The advised workaround does not work.

    1
  • Avatar

    Russell Kent

    Be advised that Malwarebytes sometimes interferes with IIS running. We have IIS configured appropriately, but it wasn't listening on port 80, and IIS Manager showed the site stopped with no "start" option available. To remediate, we halted Malwarebytes, completely uninstalled IIS, restarted the server, stopped Malwarebytes again (it restarted with the server reboot), re-installed IIS, removed all the .Net 6.0.18 stuff that the "External Components" package added, installed the .Net 3.1 Windows Server Hosting package (from https://dotnet.microsoft.com/en-us/download/dotnet/3.1 ) and then re-installed FC12. We have yet to restart the server to see if Malwarebytes continues to interfere (on reboot).

    1
  • Avatar

    Nikita Shevchenko

    Sometimes you just need to reinstall .NET Core using the ABBYY distribution.

    0
  • Avatar

    Jörg Loring

    Hello, I was faced with the same problem today during an installation on a new server. I was hoping that one of the tips given here would be valuable. It is a pity that this was not the case. Neither re-installing the .Net Core component (V 6) nor re-downloading the latest ABBYY_FlexiCapture12_Distributed_R4U3_12.0.4.991.iso made any difference. The ps1 file will probably never be in the specified location. I have tried 2 things. Firstly, I installed the old version 3.1.27 from an older ISO (this is what is supposedly missing). No effect. Then I wrote the ps1 file myself and placed it in the location mentioned. No effect. Does anyone have another crazy idea? I am now opening a support ticket. Thank you very much.

    0
  • Avatar

    Anzhelika Fedko

    Jörg,

    As I see, you created a Customer Support ticket and the issue was a bit tricky.

    Just for future reference, the cause of the issue is still unknown and the solution was to reinstall FlexiCapture from scratch.

    0
  • Avatar

    Chethan Patharla

    Please go through the installation steps and enable related options in IIS.
    Restart and reinstall everything and it will work
    If you are using windows Home you need to enable something's using command prompt which are by default not available

    1
  • Avatar

    Edward Bross

    Issue still exists in 12.0.4.1016. 

    Workaround does not work because CheckIisAspNetCoreReady.ps1 does not exist in the installation media. 

    1
  • Avatar

    Matthew Liu

    It is worth mentioning that it has to uninstall and reinstall the server to recognize the CheckIisAspNetCoreReady.ps1.

    0
  • Avatar

    Alexander

    This workaround doesn't work as some users have mentioned the .ps1 script is not included, however the following step should work.

    ABBYY_FlexiCapture12_Distributed_R4U3_12.0.4.1057.iso

    1. Stop IIS
    2. Install Microsoft .Net 9.0.0 - Windows Server Hosting (Microsoft .Net Core 9.0.0)
    3. Start IIS
    4. Install ABBYY with the Application Server Web Station enabled

     

    0

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