Symptoms
- The FlexiCapture setup was updated to build 12.0.4.945.
- When trying to open any report in Administration and Monitoring > Reports:
- The CSV file shows that there are reporting data rows returned.
- The report page is broken and there's no data shown (no difference which browser is used).
Cause
Starting with build 12.0.4.945, the version of ReportViewer has changed in FlexiCapture. In particular, it has to be specified in the web.config of the Administration and Monitoring.
Along with this, the JS files that ReportViewer generates also changed. In order for the transition to the new version to occur completely, it is necessary to reset the cache on the reports page, e.g.: http://localhost/FlexiCapture12/Monitoring/WebForms/ReportViewer.aspx
Resolution
To update the web.config file for the Administration and Monitoring:
- On the machine with the Application Server installed open the following file in the text editor: C:\inetpub\wwwroot\FlexiCapture12\Monitoring\Web.config
- Remove 33'rd row:
<add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" validate="false" /> - Add this row instead:
<add verb="*" path="Reserved.ReportViewerWebControl.axd" type = "Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=15.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" /> - Remove 105'th row:
<add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" /> - Add this row instead:
<add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=15.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />
The steps mention rows 33 and 105, but on-premise installation might have these strings on different rows, e.g. rows 48 and 127 respectively for my test (better search for the matching content via Ctrl + F).
To reset the cache for the reports page:
- generate one of the reports and check the page's URL in the address line, it should be similar to the following address:
http://localhost/FlexiCapture12/Monitoring/WebForms/ReportViewer.aspx - remove the cache for the page and refresh it (this can be done with the Ctrl + Shift + R keyboard shortcut).
Comments
0 comments
Please sign in to leave a comment.