SSL/TLS certificate-related errors in logs during document processing

Symptoms

Errors as per below appear in logs every time when processing documents:

  • System.ServiceModel.Security.SecurityNegotiationException: Could not establish trust relationship for the SSL/TLS secure channel with authority 'XXXXXXX'.

  • System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

  • System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure. 

Cause

The errors indicate an expired or incorrect SSL Certificate installed on the IIS server. Since the handshake cannot be done between the two sides, a trusted connection through HTTPS cannot be established as a result. 

Resolution

Please check the SSL certificate validity.

Additional information

Securing your network connections

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.