Flexicapture 12: Processing Server can't connect to the Application Server.

Symptoms

The Processing Server can't connect to the Application Server, which causes looped restarting of the server.

Cause

This can be caused by the incorrect resolving of the Application Server name or some firewall rules.

The following errors can be observed in the Windows Event Viewer log > Applications.

FlexiBr: Error creating an Application Server session: Cannot connect to 'applicationserveraddress' (error code: 12007).

Resolution

Please do the following:

  1. Make sure that Processing Server is correctly configured and the corresponding user for it is created: 
    https://help.abbyy.com/en-us/flexicapture/12/admin_guide/processing_server_setup/
  2. Check the application server name specified in the Processing Server properties:
    mceclip0.png
    Please note. If you are using a non-secure connection, then the address should contain http in the beginning.
  3. Check firewall rules:
    1. On the machine with a Processing server, port 10024 should be open.
      You can check this with the PowerShell command:
      Test-Netconnection -p 10024 %ProcessingServermahcineDNS%

    2. On the Application Server machine port 80 (if HTTP is used) or port 443 (if HTTPS is used) should be open.
      You can check this with the PowerShell command:
      Test-Netconnection -p 80 %ApplicationServermahcineDNS%

Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.