Project upload to the server fails due to "memory pressure" error in FlexiCapture 12

Symptoms 

In FlexiCapture 12, an attempt to upload project to server fails with the warning message:

The app domain with specified version <version ID> was unloaded due to memory pressure and could not be found. in method { call BatchItem_Get(?, ?, ?, ?, ?) }

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Note. The method specified in the error text can be different.

Cause

The error is referring to the stored procedure in the FC database. Such kind of errors indicates the database resources or performance inconsistency.

Resolution

The following approaches can be used to resolve the error.

Approach 1 (general). Increase the database server available machine resources (RAM at first place).

Approach 2. Increase the FlexiCapture HTTP communication timeout using the registry key HttpWaitTimeout at the FlexiCapture Application Server and File Storage machine(s) in a corresponding registry branch, as follows:

  • x32 environment:
    [HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\12.0\Controller\EnterpriseClientProxy]HttpWaitTimeout ="6000000"
  • x64 environment:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ABBYY\FlexiCapture\12.0\Controller\EnterpriseClientProxy]HttpWaitTimeout="6000000"

Note. The 6000000 values should be added as a type string, without quotes.

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